Joomla 3 -> Joomla 4: how to keep template work correctly?

  • Hi Guest, Welcome to SN 2.0, A new start, towards making this forum great once again. A lot has happenned in the last 6 months along with a world Pandemic. As you can realize that this is a new site and i have tried to recover as much as possible from the old version but pls expect some areas which might be lost forover or replaced with better things. 1. Payment Options 2. Resources(Rebuild) 3. Fixing all Prefixes 4. Permissions & Forum Moderation are some areas which are being worked upon. I will continue to update all of you via this notification as i work in the background to get you the best experience. Lastly we will also clarify about the issues we have had. Pls have Patience as we fix all credits wallets on priority. Best Regards, SN Team. Stay Safe.
K

kuentabazura

New member
Aug 7, 2019
2
1
0
Credits
39
I am wondering about the same. Also for plugins. Will 3.x compatible ones be compatible with 4.x?
 
  • Like
Reactions: Ghassen
T

tobizimmi

SN Confirmed Member
Aug 7, 2019
6
11
0
Credits
98
I think in most cases they should be also compatible with Joomla 4.x. But I think the scripts need firstly be checked before. But I'm not 100 % sure. I could also find nothing about this in the internet.

If someone hast reliable information would be also interesting for me.
 
S

student2006

New member
Apr 19, 2017
6
1
0
Credits
35
I read that the structure has changed quite a lot, and the template will most likely need to be edited
 
M

mikajaxxx

SN Confirmed Member
Dec 18, 2017
8
40
0
Credits
264
in my oponion you may wait at least 6 mounth until the new version of joomla become stable enough and the extensions released. do not hurry to upgrade joomla for every major release!
 
J

jayb

SN Confirmed Member
Jan 3, 2019
20
26
0
Credits
107
in my oponion you may wait at least 6 mounth until the new version of joomla become stable enough and the extensions released. do not hurry to upgrade joomla for every major release!
I think you are right although you have to test all your sites before in dev staging environment in order to find the conflicting extensions or troubled sections of your template, in order to decide if you are going to make the upgrade
 
  • Like
Reactions: Zoomer
Zoomer

Zoomer

The One and Only
Master VIP
Mar 10, 2019
63
134
33
Not close to you
Credits
650,759
At the moment it is still alpha. No reason to jump and have a bad awakening. I would think best at the moment to use for trial and see how it does with your site.
 
J

jayb

SN Confirmed Member
Jan 3, 2019
20
26
0
Credits
107
At the moment it is still alpha. No reason to jump and have a bad awakening. I would think best at the moment to use for trial and see how it does with your site.
That's true
 
C

CMol414939

SN Confirmed Member
Nov 8, 2018
5
11
0
Credits
260
I am sure there won't be a huge leap interims of what is required. If you make doo big of a jump, you end up loosing a lot of users. Drupal mis stepped with this on the jump from 7-8... and now even years later are still trying to bring the v7 users up to v8-9.
 
bockey

bockey

SN Confirmed Member
Dec 8, 2017
24
38
13
Credits
1,544
After upgrade to Joomla 3.10 version, you will be able to easily upgrade your Joomla to Joomla 4 version. Anyway, a lot of new features and also obsolete ones will have impact to the existing extensions and you need to check if they will work on new version. But generally there is advice to use appropriate and native components.
 
Top