Question SSL on Prestashop 1.7

  • Hi Guest, Welcome to SN 2.0, A new start, towards making this forum great once again. A lot has happenned in the last 6 months along with a world Pandemic. As you can realize that this is a new site and i have tried to recover as much as possible from the old version but pls expect some areas which might be lost forover or replaced with better things. 1. Payment Options 2. Resources(Rebuild) 3. Fixing all Prefixes 4. Permissions & Forum Moderation are some areas which are being worked upon. I will continue to update all of you via this notification as i work in the background to get you the best experience. Lastly we will also clarify about the issues we have had. Pls have Patience as we fix all credits wallets on priority. Best Regards, SN Team. Stay Safe.
Y

Yo sa

Member
Apr 7, 2019
2
5
0
Credits
40
Dear all,

Is someone can help me to activate SSL on Prestashop ?

I've already try via Generals parameters but still does'nt work
 
Last edited by a moderator:
V

veromon

SN Confirmed Member
Oct 26, 2018
8
13
0
Credits
31
You activated an ssl for cpanel? First, you must to go in cpanel, and generate an ssl key for your domain, after this you will be able to activate ssl from general parameters.
 
E

eikichiz

SN Confirmed Member
Apr 24, 2019
5
4
0
Credits
36
You can get a SSL with let's encrypt and then ask the administrator to enable it for your webserver, after that, you can enable ssl in prestashop settings.
 
  • Like
Reactions: aha903 and kdr
L

leofivecs

SN Confirmed Member
Oct 30, 2018
31
210
0
Credits
1,708
You have to enable SSL site wide ( Apache2 or other server ) first and then need to enable in Prestashop this way you run your website on SSL port 443. Lets encrypt will automatically install certificate, after SSL installation reload server with new settings.
  • Setting in 1.6x - Select Preferences -> General -> Activate Enable SSL and Enable SSL on all pages.
  • Setting in 1.7x - Select Parameters -> General -> Select Yes under Enable SSL.
 
Last edited:
C

CSSR

SN Confirmed Member
Jun 9, 2019
6
3
0
Credits
37
Do you have SSL ready & installed by your hosting provider? You can activate https:// on Presta only after that.
 
X

xpumpa

SN Confirmed Member
Oct 13, 2018
13
53
0
Credits
434
Anyone knows how to set SSL off for images only. i want to use CCC media servers speed-up for subdomains, but for subdomains a do not want buy another certificates or expensive *.domain.com certificate.
 
P

psdes

SN Confirmed Member
Jan 27, 2019
9
6
0
Credits
113
You can't have domain in https (with ssl) and subdomains in http (without ssl)
 
M

mydesigners

SN Confirmed Member
Jul 21, 2019
7
3
0
Credits
42
CSSR, use an alternative .htaccess in the subdomain which doesn't use https then it should work.
 
  • Like
Reactions: lazarotti
Z

zobi

SN Confirmed Member
Aug 6, 2018
5
3
0
Credits
72
don't forget to activate SSl on all your pages!
 
S

saniaja

SN Confirmed Member
Feb 5, 2019
8
10
0
Credits
121
What is your problem? Do you have SSL enabled on your server side? If Prestashop doesn't allow you to enable SSL then the problem is on server side SSL.
 
urameshix

urameshix

SN Confirmed Member
Dec 11, 2019
29
6
3
Worldwide
Credits
2
You have to enable ssl first in your server plesk or whatever server manager you have installed! Let's encrypt must do the work and it's free. Then you have to go to the options of prestashop an switch the option "Enable SSL", then "activate ssl in all pages" just below.

Hope it helps.
 
  • Like
Reactions: Wuamei and Zoomer
E

esref

SN Confirmed Member
Sep 20, 2019
7
5
0
Credits
7
You can get a SSL with let's encrypt
 
pereceh

pereceh

SN Confirmed Member
Aug 15, 2018
32
313
0
Credits
1,747
if you need PositiveSSL or PositiveSSL Wildcard from Sectigo you can contact me ... I will sell $5 for PositiveSSL 1 year or $20 for PositiveSSL Wildcard 1 year
 
urameshix

urameshix

SN Confirmed Member
Dec 11, 2019
29
6
3
Worldwide
Credits
2
if you don't activate SSL in your ps configuration it's possible you will get endless redirection and error 500. it happened to me
 
R

Ricardo1195

New member
May 4, 2020
2
0
0
Portugal
Credits
0
You have to verify also if you have some images in your pages that are uploaded with http url. Because if you have the SSL will not be active. You have to change URL of the images in http for https.
 
Top