1. Please Sign Up if you don't have account. And Login if you have account.


Question Xenforo 2.1 + CloudFlare? SSL, broken CSS problems

Discussion in 'General XenForo 2 Discussion' started by AlejandroSU, Jun 11, 2019.

  1. AlejandroSU

    AlejandroSU Member SN Confirmed Member

    8
    45
    13
    Hello everybody, I readed every relationatedd post on Google and I can not solve this problem on my xenforo installation. I have unckecked css minify.

    I found in this forum this tutorial but images are broken...
    Your post count must be 5 in order to see this link. You currently have 0 post(s)

    I need to can use cloudflare on my forum.

    I tryed to create cloudflare page rules but it still doesnt works

    Somebody knows how to solve this problem? Xenforo style css doesnt works on the frontend and doent works on admin panel too.
    --- Posts Merged by Spam-Bot ---
    UPDATE

    I installed the same xenforo version on localhost wamp server and int works correctly (css etc)

    After it I disabled all the SSL options on CloudFlare and I installed again Xenforo without https (ssl) and the css style problem persist.

    I have disabled css,js and html cache minify in cloudflare config so it is not the problem.

    I read in xenforo forums lots of topics about 1.5 version solutions and it doesnt works. It appears to be a reverse proxy problem but I dont find any solution for xenforo 2.0 or xenforo 2.1 and also the cloudflare post doesnt explain nothing concret : Your post count must be 5 in order to see this link. You currently have 0 post(s)
     
    Voltarre likes this.
  2. Tokio_Alive!

    Tokio_Alive! New Member SN Confirmed Member

    6
    16
    3

    You're a Guest, you don't have permission to view links. Please Register or Login to view this link.

    I installed the same xenforo version on localhost wamp server and int works correctly (css etc)

    After it I disabled all the SSL options on CloudFlare and I installed again Xenforo without https (ssl) and the css style problem persist.

    I have disabled css,js and html cache minify in cloudflare config so it is not the problem.

    I read in xenforo forums lots of topics about 1.5 version solutions and it doesnt works. It appears to be a reverse proxy problem but I dont find any solution for xenforo 2.0 or xenforo 2.1 and also the cloudflare post doesnt explain nothing concret : Your post count must be 5 in order to see this link. You currently have 2 post(s)
    Click to expand...
    In the first place you need to enable the developer navegator mode in opera (control + Shif + C) in other navegators like Firefox F12 and check in the console part if you have broken links (url) and see where is the address your css are pointing, remember that using cloudfire and Security certificate your url change to SSL, (http"S") and if your forum software is pointing to (http) they would not be loaded, you can start from there. You also can check your .httacces file but need to know what you are doing. Greetings.
     
    Voltarre likes this.

Share This Page

Turning cookies on makes it easier for you to browse the web. Cookies are files created by websites you’ve visited, which store information, like the language you prefer or profile information. At Scriptznull, we use cookies to improve the quality of our service. Check our Privacy Policy for more information about cookies. Okay More information